SYSTEM REQUIREMENTS

As a new Q-global user, you will need the following:

  • A computer with access to the Internet through a standard browser (e.g., Safari®, Microsoft® Internet Explorer® 11.0 or above, etc.)
  • A Q-global account that has been activated and credited for use.


Your operating system and browser should show up in the list below in order to run the Q-global software:

  • Operating Systems
    Windows® 7
    Windows 8
    Windows 10
    Mac OS® 10.9 or higher

  • Browsers
    IE 11.0
    Edge
    Chrome
    Firefox®
    Safari®